Unplanned Outage - RMC Online Training

Incident Report for Novara

Resolved

This incident has been resolved.
Posted Jul 06, 2026 - 14:00 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 06, 2026 - 13:29 MDT

Investigating

Users are unable to access the systems listed below. The Novara Technology team is currently looking into the issue.
Posted Jul 06, 2026 - 13:25 MDT
This incident affected: Risk Management Center (Employee Portal).